Admin- / ISP-Software » Plesk

ID #1403 Plesk 10: sa-update liefert Fehlermeldung im Cronjob

(Gefunden bei Net-Publics: PLESK 10.0.1 run-parts: failed to exec /etc/cron.daily/60sa-update: Exec format error)

Problem:

Der Cronjob des SpamAssassin-Updater wie er bei Plesk 10.0.1 mitgeliefert wird, liefert einen Fehler per Email (=> root-Emails lesen):

/etc/cron.daily/60sa-update:
run-parts: failed to exec /etc/cron.daily/60sa-update: Exec format error
run-parts: /etc/cron.daily/60sa-update exited with return code 1

Lösung:

Der Fehler liegt in der Shebang-Zeile der Datei /etc/cron.daily/60sa-update. Hier wurde das Ausrufezeichen vergessen. Ändert diese Zeile wie folgt ab:

#!/bin/sh

Danach sollte der Fehler nicht

 

sozial Bookmarking
Bookmarken bei YIGG Bookmarken bei Mister-Wong Bookmarken bei Icio Bookmarken bei del.icio.us Bookmarken bei Technorati Bookmarken bei Furl Bookmarken bei Spurl Bookmarken bei Yahoo Bookmarken bei Google

vom 2010-11-23 11:58, zuletzt 2010-11-23 12:02     Artikel ausdrucken Artikel weiterempfehlen Als PDF-Datei anzeigen

Dieser Inhalt ist unter der Creative-Commons Lizenz lizensiert.

Probleme bitte im Server-Support-Forum diskutieren.

überflüssig 1 2 3 4 5 wertvoll  
Durchschnittliche Bewertung:   5 von 5 (1 Bewertungen)

Artikel kommentieren

Kommentar von Eric (2010-12-17 00:11:34):
Und wenn die Fehlermeldung bleibt???

*** /etc/psa/plesk-cron.daily/50plesk-daily Completed ***
*** /etc/psa/plesk-cron.daily/60sa-update Failed (code=1) ***


Obwohl

#!/bin/sh

# Only restart spamd if sa-update returns 0, meaning it updated the rules
/usr/bin/sa-update && /etc/init.d/psa-spamassassin restart | tee -a /var/log/sa-update.log
/etc/psa/plesk-cron.daily/60sa-update lines 1-4/4 (END)

Kommentar von huschi (2010-12-17 13:25:23):
@Eric:
Man muss auch bei der Shebang-Zeile aufpassen. U.a. dass man keinen Windows-Editor nimmt.

huschi.

Kommentar von Willi (2010-12-28 22:23:22):
Ich hatte auch das Problem das ich nach dem Einfügen des "!" immer noch die Meldung des Return-Codes hatte. Ich habe dann unter http://blog.net-publics.de/2010/11/29/plesk-10-0-1-run-parts-etccron-daily60sa-update-exited-with-return-code-1/ einen weiteren Hinweis gefunden.

Grüße,
Willi