Mail-Server » Qmail

ID #1179 qmail: Die Mail-Queue wird nicht abgearbeitet

Problem:

Frische Mails landen zwar in der Mail-Queue, werden aber nicht abgearbeitet. Erst ca. 30 Minuten später werden diese Mails verschickt. (Kann im Logfile klar nach vollzogen werden.)

Erklärung:

qmail-queue und qmail-send kommunizieren mittels eine benannten Pipe namens /var/qmail/queue/lock/trigger. Wenn diese Pipe verstopft ist, beachtet qmail-send neue Nachrichten für etwa eine halbe Stunde nicht.

Lösung:

a) Entweder im Quellverzeichnis make check aufrufen.
b) Oder die Named-Pipe per Hand erstellen, so das sie wie folgt aussieht:

prw--w--w- 1 qmails qmail 0 Jul 5 21:25 /var/qmail/queue/lock/trigger

Vorallem das p, der Schreibzugriff für alle und die Benutzter/Gruppe müssen entsprechend gesetzt sein.
Beispiel:

mkfifo -m 622 /var/qmail/queue/lock/trigger
chown qmails:qmail /var/qmail/queue/lock/trigger

 

sozial Bookmarking
Bookmarken bei YIGG Bookmarken bei Mister-Wong Bookmarken bei Icio Bookmarken bei del.icio.us Bookmarken bei Technorati Bookmarken bei Furl Bookmarken bei Spurl Bookmarken bei Yahoo Bookmarken bei Google

vom 2006-07-29 17:07, zuletzt 2007-12-06 11:47     Artikel ausdrucken Artikel weiterempfehlen Als PDF-Datei anzeigen

Dieser Inhalt ist unter der Creative-Commons Lizenz lizensiert.

Probleme bitte im Server-Support-Forum diskutieren.

überflüssig 1 2 3 4 5 wertvoll  
Durchschnittliche Bewertung:   5 von 5 (1 Bewertungen)

Artikel kommentieren

Kommentar von Norbert (2038-01-19 03:14:07):
Klingt genau wie mein Prob.
Nur leider wird
a) mit command not found
b) mit ungültiger Zugriffsmodus von Debian 3.1 quittiert.

Kommentar von Alexander Dehoff (2006-07-29 13:43:36):
Hallo,

das Kommando
mkfifo -m a=444 /var/qmail/queue/lock/trigger
ist vermutlich nicht ganz richtig, da nur
mkfifo -m 444 /var/qmail/queue/lock/trigger
bei mir unter Sarge funktioniert.

Schönen Gruß

Alexander

Kommentar von huschi (2006-07-29 15:11:19):
"mkfifo -m a=444" ist tatsächlich die alte Schreibart.
Danke für den Hinweiß.

Kommentar von Nasdero (2007-07-30 18:20:27):
622 sollen die Rechte sein, nicht 644, mit 622 geht es wieder bei mir!